Bugs in (Advanced) Search

Moderators: dwp, devin

Post Reply
AlCan
Posts: 150
Joined: Thu Feb 23, 2012 10:00 pm
Location: New Zealand

Bugs in (Advanced) Search

Post by AlCan » Wed Jul 03, 2013 10:12 pm

Hi DWP,

I have been having some issues with the Advanced Search tab.

The other day, I couldn't search normally. When I went to type in the search string, a dropdown list appeared, which I think showed all the previous searches I have used. However, it wouldn't let me type in a new search and insisted that I use one of the old search strings. I can't really remember now exactly what happened, but I think I even got a message box telling me that. But it doesn't behave like this today. The old search list still appears but I can enter a new search. I wonder if anyone else has had this problem?

However, there is definitely another problem with the settings. I remember there was a problem like this with the 'Prompt before exit' control where it got turned off incidentally somehow. This is happening with the Search tab settings: Settings > Detail view settings > Search > Items to show. I want Numbers, Organization, Title, Groups, Dial button and Notes. However, whenever I set Numbers and exit, the Numbers are not displayed, just a blank line. When I look, the Numbers option is now unselected. This should not happen, but, if it's not selected, shouldn't the empty line be omitted as well?

Can you have a look at this please?

Cheers,
A
Currently (i.e Now, not necessarily the date of this post)
using DW Contacts & Dialer version 2.5.3.0-pro
On Motorola Defy with Android 2.2.2 (Work Phone)

dwp
Site Admin
Posts: 713
Joined: Mon Nov 22, 2010 4:46 pm

Re: Bugs in (Advanced) Search

Post by dwp » Thu Jul 04, 2013 4:24 am

Hello
I do not know what happened which caused not enter. You can do a screen capture you?
Search all fields are now open, does not support the display of the phone number. The second line shows the matching fields.

AlCan
Posts: 150
Joined: Thu Feb 23, 2012 10:00 pm
Location: New Zealand

Re: Bugs in (Advanced) Search

Post by AlCan » Thu Jul 04, 2013 10:58 pm

Hi DWP,
dwp wrote:You can do a screen capture you?
Sorry, can't do in Android 2.2.2. Would need to root the phone, but it's my Work phone so probably shouldn't try.
dwp wrote:does not support the display of the phone number.
Ok, but I don't understand. If you go to Search > Settings > Items to show, Numbers is listed at the top of the Items to show list. But you are saying you can't enable it. So it should be removed from that list? Funny thing is, it doesn't display Numbers even before running a search.
dwp wrote: The second line shows the matching fields.
Actually, there's a problem there as well. I have a contact with an Organisation name that is like this:

Seventy Eight Nine

However, if I search on Nine, the second line only shows "Seventy Eight", even though there is plenty of room left on the line.

If I turn off Show Organisation, the "Nine" appears on the 3rd line. If I have Show Organisation On, it shows the normal (coloured background) Organisation name in the 3rd line, but only shows "Seventy Eight" on the 2nd line, so you can't see the matching data in the 2nd line.

Also, I have a contact named Nigel Goldstien. His entry has no Organisation name. If I search on Gold, the result shows like this:

Nigel Goldstien
Nigel
Goldstien


I'm sure it's not supposed to go onto the 3rd line?

However, if I search for an address and the result address has two lines, I get worse errors. If the contact has a Job Title (Position) entered, this appears (with coloured background) over the top of the 2nd line of the address in the 3rd line. For example:

Contact Name
Address Line 1
[Title]ss Line 2


I guess this isn't how it's intended to look, though I guess it could also be hard to fix? Actually, if you just extract the matching line and display only that, I guess it would work.

Best regards,
Al
Currently (i.e Now, not necessarily the date of this post)
using DW Contacts & Dialer version 2.5.3.0-pro
On Motorola Defy with Android 2.2.2 (Work Phone)

dwp
Site Admin
Posts: 713
Joined: Mon Nov 22, 2010 4:46 pm

Re: Bugs in (Advanced) Search

Post by dwp » Fri Jul 05, 2013 3:28 am

Hello
Thank you for your feedback. I also found this bug. In 2.5.2.0, I draw text instead of using TextView, is used to provide a list scrolling speed. This led to the failure. I will try to solve this problem.

dwp
Site Admin
Posts: 713
Joined: Mon Nov 22, 2010 4:46 pm

Re: Bugs in (Advanced) Search

Post by dwp » Wed Jul 31, 2013 4:18 am

Hello AI
I have uploaded a new file to http://dw-p.net/dl/DW-Contacts-Phone-test.apk
If possible, please try if it works?

AlCan
Posts: 150
Joined: Thu Feb 23, 2012 10:00 pm
Location: New Zealand

Re: Bugs in (Advanced) Search

Post by AlCan » Wed Aug 14, 2013 11:41 pm

Hi DWP,

Sorry for the delay, haven't been to the Forum for while...

I downloaded and installed the Test version. Many thanks for that.

However, it installed into a different location, so I now have 2.5.3.0 installed as well as the Test version. But the Test version does not use any of my settings - everything was set to Default. Ok, so I restored my Settings Backup to it - that worked. Now using my settings.

Yes, I can say that the problem with the Search Box dropdown list is gone. Yes, it does still offer the dropdown list, but only when you tap into the Search string box when it's empty. That's very nice, it behaves very well on my phone. It doesn't prevent the Keyboard from appearing and it doesn't overlay the keyboard until you try to select an entry. That works very nicely too. And the dropdown list goes away as soon as you type a character for a fresh search.

Also, the Results display seems to be fixed as well. At least, I haven't seen any problems with overlaying etc. It all looks fine. Still the same issue with the Seventy Eight Nine search though. The bottom line shows

Seventy Eight

in bold, but doesn't show the Nine at all, even when the search string is "nine". I'm generally a bit confused about how the last line is displayed. If it's matching the Organisation name, it seems to only display the first one or two words, but if it's in the address, it displays as much as it can with ... at the end if it's too long. Can that be applied to all results in the last line?

Oh, and rotating the phone messes up the search result, and causes it to clear and restart. Not sure if that's avoidable?

Only displays 3 lines in landscape and 4 in portrait mode - I think that's setting controlled? And maybe that's why it restarts?

Apart from that, very well done. Thanks.

I do have some issues with having two installations on my phone but I'm sure I can live with that. Thanks for your effort and good work!

(I hope you had a good trip - was it a holiday?) Any developments with the Recent Calls list icons - or do I need to redo all my settings to fix that?

Best regards,
Al
Currently (i.e Now, not necessarily the date of this post)
using DW Contacts & Dialer version 2.5.3.0-pro
On Motorola Defy with Android 2.2.2 (Work Phone)

dwp
Site Admin
Posts: 713
Joined: Mon Nov 22, 2010 4:46 pm

Re: Bugs in (Advanced) Search

Post by dwp » Thu Aug 15, 2013 12:53 am

Hi Al
Thank you for your testing,
Search History Save your searches recently tried several search string. So when you enter a new search string will clear out some old data.

Sorry I did not find the problem in the call log icon. Restore the default settings can solve the problem?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest