Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Moderators: dwp, devin

Post Reply
rks888
Posts: 3
Joined: Wed Apr 15, 2015 6:34 pm

Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by rks888 » Wed Apr 15, 2015 6:38 pm

After recent upgrade to Android 5.0 DWP stops working properly - instead of dialing number (after pressing DWP button configured Sim1 or Sim2) always invokes "Complete action using" system dialogue (e.g. embedded Phone or Skype etc)

devin
Posts: 1068
Joined: Fri Oct 11, 2013 10:16 am

Re: Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by devin » Thu Apr 16, 2015 1:04 am

Hello
Have you try to configure here?
Toolbox TAB -> Dual Sim card configuration

rks888
Posts: 3
Joined: Wed Apr 15, 2015 6:34 pm

Re: Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by rks888 » Thu Apr 16, 2015 6:41 am

Yes sure!
I've setup the Dual Sim config screen (see Screenshot 1) - I've tried all "Device:" options, and all produce the same outcome except for Generic 3 which does not do anything.
So when I push test call on Sim 1 or Sim 2 the same result - see Screenshot 2.
Attachments
Screenshot_2.png
Screenshot_2.png (135.17 KiB) Viewed 501 times
Screenshot_1.png
Screenshot_1.png (193.56 KiB) Viewed 501 times

devin
Posts: 1068
Joined: Fri Oct 11, 2013 10:16 am

Re: Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by devin » Fri Apr 17, 2015 2:03 am

Select Phone is the default, and then continue.

rks888
Posts: 3
Joined: Wed Apr 15, 2015 6:34 pm

Re: Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by rks888 » Fri Apr 17, 2015 5:33 am

Done that!
Apologies, missed an important detail - as soon as DWP invokes embedded Phone app to complete the call, additional system query appears asking which SIM to use (see attach). This was not happening on previous 4.4.4 OS version as DWP was able to start calling from the right card immediately. Actually this behaviour makes separate buttons for different sims in DWP useless :(
Attachments
Screenshot_3.png
Screenshot_3.png (38.54 KiB) Viewed 490 times

devin
Posts: 1068
Joined: Fri Oct 11, 2013 10:16 am

Re: Lollipop & Sony Xperia Z3 Dual Sim (D6633) bug

Post by devin » Tue Apr 21, 2015 1:48 am

Hello
Try different devices, if it can not work. No good way, because there is no public API.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest